https://github.com/mcuadros/go-syslog
go rfc3164 rfc5424 rfc6587 server syslog
Score: 27.351449955160035
Last synced: about 15 hours ago
JSON representation
Repository metadata:
Syslog server library for go.
- Host: GitHub
- URL: https://github.com/mcuadros/go-syslog
- Owner: mcuadros
- License: mit
- Created: 2013-12-25T01:32:21.000Z (almost 13 years ago)
- Default Branch: master
- Last Pushed: 2023-11-09T14:17:43.000Z (almost 3 years ago)
- Last Synced: 2026-10-24T09:54:53.886Z (6 days ago)
- Topics: go, rfc3164, rfc5424, rfc6587, server, syslog
- Language: Go
- Homepage: http://godoc.org/gopkg.in/mcuadros/go-syslog.v2
- Size: 146 KB
- Stars: 544
- Watchers: 22
- Forks: 143
- Open Issues: 36
-
Metadata Files:
- Readme: README.md
- License: LICENSE
Owner metadata:
- Name: Máximo Cuadros
- Login: mcuadros
- Email: mcuadros@gmail.com
- Kind: user
- Description:
- Website:
- Location: Madrid, Spain
- Twitter:
- Company:
- Icon url: https://avatars.githubusercontent.com/u/1573114?u=60bb7669d1713c45f4f1c5b8c15f0dc8e7a46e10&v=4
- Repositories: 105
- Last Synced at: 2026-10-24T09:41:42.632Z
- Profile URL: https://github.com/mcuadros
GitHub Events
Total
- Fork event: 3
- Issue comment event: 4
- Issues event: 1
- Pull request event: 3
- Watch event: 12
- Total: 23
Last Year
- Watch event: 4
- Total: 4
Committers metadata
Last synced: 13 days ago
Total Commits: 134
Total Committers: 19
Avg Commits per committer: 7.053
Development Distribution Score (DDS): 0.56
Commits in past year: 0
Committers in past year: 0
Avg Commits per committer in past year: 0.0
Development Distribution Score (DDS) in past year: 0.0
| Name | Commits | |
|---|---|---|
| Jérôme Renard | j****d@g****m | 59 |
| Máximo Cuadros | m****s@g****m | 33 |
| Alex Bligh | a****x@a****k | 11 |
| Dane Elwell | d****l@u****k | 6 |
| Isaac Saldana | i****c@s****m | 5 |
| Cezar Sa Espinola | c****a@g****m | 4 |
| Emmanuel Gomez | e****l@g****o | 3 |
| Edward Muller | e****m@i****m | 2 |
| Antonino Catinello | c****o | 1 |
| Arne Claus | a****s@t****m | 1 |
| BoySka | b****a | 1 |
| Eugene Pimenov | e****e@l****t | 1 |
| Guy Lichtman | 1****t | 1 |
| Igor Anić | i****c@m****r | 1 |
| Nilton Kummer | n****r@g****m | 1 |
| Patrick Pokatilo | m****l@s****t | 1 |
| Quinn Slack | q****k@q****m | 1 |
| Stéphane Cottin | s****n@v****m | 1 |
| Tim Shimmin | t****n@g****m | 1 |
Issue and Pull Request metadata
Last synced: 13 days ago
Total issues: 37
Total pull requests: 59
Average time to close issues: about 2 months
Average time to close pull requests: 5 months
Total issue authors: 35
Total pull request authors: 34
Average comments per issue: 0.97
Average comments per pull request: 1.08
Merged pull request: 29
Bot issues: 0
Bot pull requests: 0
Past year issues: 0
Past year pull requests: 0
Past year average time to close issues: N/A
Past year average time to close pull requests: N/A
Past year issue authors: 0
Past year pull request authors: 0
Past year average comments per issue: 0
Past year average comments per pull request: 0
Past year merged pull request: 0
Past year bot issues: 0
Past year bot pull requests: 0
Top Issue Authors
- fmaylinch (2)
- abligh (2)
- angelyouyou (1)
- whuben (1)
- jonnsl (1)
- cezarsa (1)
- genofire (1)
- alivardar (1)
- ldelossa (1)
- lph110 (1)
- helinwang (1)
- stapelberg (1)
- ChristianKniep (1)
- dsvensson (1)
- ianic (1)
Top Pull Request Authors
- abligh (9)
- cezarsa (4)
- munkyboy (4)
- isaldana (4)
- glicht (3)
- rfyiamcool (3)
- emmanuel (2)
- freeformz (2)
- rtgnx (2)
- cnaude (2)
- sqs (1)
- SHyx0rmZ (1)
- DavaOps (1)
- arikastarvo (1)
- boyska (1)
Top Issue Labels
Top Pull Request Labels
Package metadata
- Total packages: 6
- Total downloads: unknown
- Total docker downloads: 68,609,695
- Total dependent packages: 202 (may contain duplicates)
- Total dependent repositories: 2,341 (may contain duplicates)
- Total versions: 17
proxy.golang.org: gopkg.in/mcuadros/go-syslog.v2
Syslog server library for go, build easy your custom syslog server over UDP, TCP or Unix sockets using RFC3164, RFC5424 and RFC6587
- Homepage: https://github.com/mcuadros/go-syslog
- Documentation: https://pkg.go.dev/gopkg.in/mcuadros/go-syslog.v2#section-documentation
- Licenses: MIT
- Latest release: v2.3.0 (published about 7 years ago)
- Last Synced: 2026-10-27T11:41:17.570Z (3 days ago)
- Versions: 6
- Dependent Packages: 201
- Dependent Repositories: 2,337
- Docker Downloads: 68,609,695
-
Rankings:
- Dependent repos count: 0.17%
- Dependent packages count: 0.282%
- Docker downloads count: 0.322%
- Average: 1.152%
- Forks count: 2.346%
- Stargazers count: 2.639%
proxy.golang.org: github.com/mcuadros/go-syslog
Syslog server library for go, build easy your custom syslog server over UDP, TCP or Unix sockets using RFC3164, RFC5424 and RFC6587
- Homepage: https://github.com/mcuadros/go-syslog
- Documentation: https://pkg.go.dev/github.com/mcuadros/go-syslog#section-documentation
- Licenses: MIT
- Latest release: v2.3.0+incompatible (published about 7 years ago)
- Last Synced: 2026-10-17T11:21:55.059Z (13 days ago)
- Versions: 7
- Dependent Packages: 1
- Dependent Repositories: 4
-
Rankings:
- Forks count: 2.357%
- Dependent repos count: 2.583%
- Stargazers count: 2.671%
- Average: 3.192%
- Dependent packages count: 5.155%
proxy.golang.org: gopkg.in/mcuadros/go-syslog.v1
Syslog server library for go, build easy your custom syslog server over UDP, TCP or Unix sockets using RFC3164 or RFC5424
- Homepage: https://github.com/mcuadros/go-syslog
- Documentation: https://pkg.go.dev/gopkg.in/mcuadros/go-syslog.v1#section-documentation
- Licenses: MIT
- Latest release: v1.3.0 (published over 11 years ago)
- Last Synced: 2026-10-17T11:21:55.167Z (13 days ago)
- Versions: 1
- Dependent Packages: 0
- Dependent Repositories: 0
-
Rankings:
- Forks count: 1.49%
- Stargazers count: 1.687%
- Average: 4.881%
- Dependent packages count: 6.999%
- Dependent repos count: 9.346%
ubuntu-22.04: golang-gopkg-mcuadros-go-syslog.v2
- Homepage: https://github.com/mcuadros/go-syslog
- Licenses: mit
- Latest release: 2.2.1-1 (published 9 months ago)
- Last Synced: 2026-03-07T04:44:42.199Z (8 months ago)
- Versions: 1
- Dependent Packages: 0
- Dependent Repositories: 0
-
Rankings:
- Dependent repos count: 0.0%
- Dependent packages count: 0.0%
- Average: 100%
debian-10: golang-gopkg-mcuadros-go-syslog.v2
- Homepage: https://github.com/mcuadros/go-syslog
- Documentation: https://packages.debian.org/buster/golang-gopkg-mcuadros-go-syslog.v2
- Licenses: mit
- Latest release: 2.2.1-1 (published 9 months ago)
- Last Synced: 2026-07-25T18:03:04.757Z (3 months ago)
- Versions: 1
- Dependent Packages: 0
- Dependent Repositories: 0
-
Rankings:
- Dependent repos count: 0.0%
- Dependent packages count: 0.0%
- Average: 100%
ubuntu-20.04: golang-gopkg-mcuadros-go-syslog.v2
- Homepage: https://github.com/mcuadros/go-syslog
- Licenses: mit
- Latest release: 2.2.1-1 (published 9 months ago)
- Last Synced: 2026-03-08T04:57:27.787Z (8 months ago)
- Versions: 1
- Dependent Packages: 0
- Dependent Repositories: 0
-
Rankings:
- Dependent repos count: 0.0%
- Dependent packages count: 0.0%
- Average: 100%