https://github.com/secure-systems-lab/go-securesystemslib
Cryptographic and general-purpose routines for Golang Secure Systems Lab projects at NYU
Last synced: 09 Oct 2026
https://github.com/lestrrat-go/httprc
Quasi Up-to-date HTTP In-memory Cache
Last synced: 09 Oct 2026
https://github.com/thysultan/stylis
light β weight css preprocessor
css preprocessor
Last synced: 09 Oct 2026
https://github.com/kevva/is-gzip
Check if a Buffer/Uint8Array is a GZIP file
Last synced: 09 Oct 2026
https://github.com/IonicaBizau/regex-parser.js
:expressionless: A module that parses a string as regular expression and returns the parsed value
hacktoberfest
Last synced: 09 Oct 2026
https://github.com/pillarjs/router
Simple middleware-style router
http javascript nodejs router
Last synced: 09 Oct 2026
https://github.com/pnpm/get-npm-tarball-url
Create the tarball URL of a npm package
Last synced: 09 Oct 2026
https://github.com/nexdrew/which-module
:m: Find the module object for something that was require()d
import lookup module nodejs require reverse
Last synced: 09 Oct 2026
https://github.com/geisbruch/node-simple-lru-cache
Simple and Fast LRU cache for node
Last synced: 09 Oct 2026
https://github.com/spdx/tools-golang
Collection of Go packages to work with SPDX files
Last synced: 09 Oct 2026
https://github.com/bmeck/node-cookiejar
Simple cookie library for node (not bound to request)
Last synced: 09 Oct 2026
https://github.com/chukaofili/olympus
CLI for auto deploying kubernetes apps
automation cli deployment kubernetes nodejs
Last synced: 09 Oct 2026
https://github.com/youmark/pkcs8
Go package implementing functions to parse and convert private keys in PKCS#8 format, as defined in RFC5208 and RFC5958
golang parse pkcs8
Last synced: 09 Oct 2026
https://github.com/frankban/quicktest
Quick helpers for testing Go applications
assertions go golang library testing
Last synced: 09 Oct 2026
https://github.com/sony/gobreaker
Circuit Breaker implemented in Go
circuit-breaker golang microservice
Last synced: 09 Oct 2026
https://github.com/jslicense/spdx-license-ids
a list of SPDX license identifiers
array javascript json license list nodejs oss spdx
Last synced: 09 Oct 2026
https://github.com/fastify/fast-uri
Dependency-free RFC 3986 URI toolbox
fastify-core uri uri-parser
Last synced: 09 Oct 2026
https://github.com/NaturalIntelligence/strnum
String to Number based on configuration
Last synced: 09 Oct 2026
https://github.com/npm/write-file-atomic
Write files in an atomic fashion w/configurable ownership
npm-cli
Last synced: 09 Oct 2026
https://github.com/syntax-tree/mdast-util-to-hast
utility to transform mdast to hast
hast hast-util html markdown mdast mdast-util syntax-tree unist
Last synced: 09 Oct 2026
https://github.com/ljharb/set-proto
Robustly set the [[Prototype]] of an object. Uses the best available method.
Last synced: 09 Oct 2026
https://github.com/chenglou/tween-functions
Robert Penner's easing functions, slightly modified
Last synced: 09 Oct 2026
https://github.com/sindresorhus/is-docker
Check if the process is running inside a Docker container
Last synced: 09 Oct 2026
https://github.com/vbatts/tar-split
checksum-reproducible tar archives (utility/library)
checksum disassembly golang payload tar-archive
Last synced: 09 Oct 2026
https://github.com/moxystudio/node-cross-spawn
A cross platform solution to node's spawn and spawnSync
cmd cross-platform exec path-ext shebang spawn windows
Last synced: 09 Oct 2026
https://github.com/wraithgar/node-promise-retry
Retries a function that returns a promise, leveraging the power of the retry module.
Last synced: 09 Oct 2026
https://github.com/sindresorhus/read-package-up
Read the closest package.json file
Last synced: 09 Oct 2026
https://github.com/sindresorhus/resolve-cwd
Resolve the path of a module like `require.resolve()` but from the current working directory
Last synced: 09 Oct 2026
https://github.com/sindresorhus/strip-final-newline
Strip the final newline character from a string/buffer
Last synced: 09 Oct 2026
https://github.com/mongoosejs/mpath
Get/set javascript object values using MongoDB-like path notation.
Last synced: 09 Oct 2026
https://github.com/defunctzombie/node-process
process information for node.js and browsers
Last synced: 09 Oct 2026
https://github.com/tvcutsem/harmony-reflect
ES5 shim for ES6 Reflect and Proxy objects
javascript metaprogramming proxies reflection shim
Last synced: 09 Oct 2026
https://github.com/open-telemetry/opentelemetry-proto-go
Generated code for OpenTelemetry protobuf data model
otel protobuf
Last synced: 09 Oct 2026
https://github.com/silverwind/cidr-regex
Regular expression for matching IP addresses in CIDR notation and bare IP addresses
cidr ip javascript module nodejs
Last synced: 09 Oct 2026
https://github.com/pmndrs/react-spring
βοΈ A spring physics based React animation library
animation-library react react-spring spring-physics springs
Last synced: 09 Oct 2026
https://github.com/awslabs/aws-solutions-constructs
The AWS Solutions Constructs Library is an open-source extension of the AWS Cloud Development Kit (AWS CDK) that provides multi-service, well-architected patterns for quickly defining solutions
architectural-patterns aws-cdk constructs
Last synced: 09 Oct 2026
https://github.com/wooorm/character-entities
Map of named character references.
character entity html reference
Last synced: 09 Oct 2026
https://github.com/unjs/pkg-types
Node.js utilities and TypeScript definitions for package.json and tsconfig.json
Last synced: 09 Oct 2026
https://github.com/mafintosh/multicast-dns
Low level multicast-dns implementation in pure javascript
Last synced: 09 Oct 2026
https://github.com/jimmywarting/FormData
HTML5 `FormData` polyfill for Browsers and nodejs
formdata html5 polyfill
Last synced: 09 Oct 2026
https://github.com/bvaughn/react-resizable-panels
group layout panel react resizable
Last synced: 09 Oct 2026
https://github.com/TooTallNate/util-deprecate
The Node.js `util.deprecate()` function with browser support
Last synced: 09 Oct 2026
https://github.com/leodido/go-urn
Parser for uniform resource names as seen on RFC 8141, RFC 2141, and RFC 7643
go hacktoberfest parser ragel rfc-2141 rfc-7643 rfc-8141 urn
Last synced: 09 Oct 2026
https://github.com/fsevents/fsevents
Native access to MacOS FSEvents in Node.js
Last synced: 09 Oct 2026
https://github.com/streamich/memfs
Node.js "fs" and browser "File System API" adapters and in-memory implementations π
browserfs cas crud file file-system filesystem fs fsa in-memory memfs memory node opfs webfs
Last synced: 09 Oct 2026
https://github.com/syntax-tree/unist-util-visit-parents
utility to recursively walk over unist nodes, with ancestral information
syntax-tree unist unist-util util visit
Last synced: 09 Oct 2026
https://github.com/hashicorp/go-version
A Go (golang) library for parsing and verifying versions and version constraints.
Last synced: 09 Oct 2026
https://github.com/es-shims/String.prototype.trimEnd
ES2019 spec-compliant String.prototype.trimEnd shim
ecmascript es6 es7 es8 polyfill proposal string tc39 trim
Last synced: 09 Oct 2026
https://github.com/browserify/randombytes
random bytes from browserify stand alone
Last synced: 09 Oct 2026
https://github.com/hapijs/joi
The most powerful data validation library for JS
hapi javascript schema validation
Last synced: 09 Oct 2026
https://github.com/theKashey/react-remove-scroll
Removes and disables πin a "React" way
react scroll
Last synced: 09 Oct 2026
https://github.com/cfware/get-package-type
Determine the `package.json#type` which applies to a location.
Last synced: 09 Oct 2026
https://github.com/node-modules/detect-port
Node.js module to detect available ports of the system.
detector free nodejs port
Last synced: 09 Oct 2026
https://github.com/theupdateframework/tuf-js
JavaScript implementation of The Update Framework (TUF)
package-security
Last synced: 09 Oct 2026
https://github.com/nock/nock
HTTP server mocking and expectations library for Node.js
http javascript mock nock node
Last synced: 09 Oct 2026
https://github.com/bruce/node-temp
Temporary File, Directory, and Stream support for Node.js
Last synced: 09 Oct 2026
https://github.com/andrewrk/node-fd-slicer
safely create multiple ReadStream or WriteStream objects from the same file descriptor
Last synced: 09 Oct 2026
https://github.com/hapijs/hoek
Node utilities shared among the extended hapi universe
Last synced: 09 Oct 2026
https://github.com/alexeyraspopov/picocolors
The tiniest and the fastest library for terminal output formatting with ANSI colors
ansi colors console terminal zero-dependency
Last synced: 09 Oct 2026
https://github.com/kulshekhar/ts-jest
A Jest transformer with source map support that lets you use Jest to test projects written in TypeScript.
jest testing typescript
Last synced: 09 Oct 2026
https://github.com/es-shims/dunder-proto
If available, the `Object.prototype.__proto__` accessor and mutator, call-bound.
Last synced: 09 Oct 2026
https://github.com/xdg-go/stringprep
Go implementation of RFC-3454 stringprep and RFC-4013 SASLprep
Last synced: 09 Oct 2026
https://github.com/tklauser/numcpus
Go package providing information about the number of CPUs in the system
bsd cpu cputopology go golang linux numa offline online unix
Last synced: 09 Oct 2026
https://github.com/tinylibs/tinyspy
π΅π»ββοΈ minimal fork of nanospy, with more features
hacktoberfest jest spy test tinylibs vite vitest
Last synced: 09 Oct 2026
https://github.com/inspect-js/data-view-byte-offset
Get the byteOffset out of a DataView, robustly.
Last synced: 09 Oct 2026
https://github.com/testing-library/jest-dom
:owl: Custom jest matchers to test the state of the DOM
custom-matcher dom dom-testing-library javascript jest jest-matchers jsdom react-testing-library testing testing-library testing-library-react
Last synced: 09 Oct 2026
https://github.com/primus/eventemitter3
EventEmitter3 - Because there's also a number 2. And we're faster.
browser eventemitter nodejs
Last synced: 09 Oct 2026
https://github.com/wooorm/web-namespaces
Map of web namespaces
html namespaces web
Last synced: 09 Oct 2026
https://github.com/react-container-query/container-query-toolkit
:wrench: Basic utilities to work with container query.
Last synced: 09 Oct 2026
https://github.com/inspect-js/which-collection
Which kind of Collection (Map, Set, WeakMap, WeakSet) is this JavaScript value? Works cross-realm, without `instanceof`, and despite Symbol.toStringTag.
collection javascript map set weakmap weakset which
Last synced: 09 Oct 2026
https://github.com/balena-io-modules/dockerignore
dockerignore is a file filter library compatible with Docker and the node-ignore API
Last synced: 09 Oct 2026
https://github.com/gregberge/svgr
Transform SVGs into React components π¦
inline-svg loader react react-native react-svg react-svg-creator react-svg-loader svg svg-react svg-to-react svg2react svgo webpack webpack-loader
Last synced: 09 Oct 2026
https://github.com/chrisdholt/exenv-es6
React's ExecutionEnvironment module extracted as ES6
Last synced: 09 Oct 2026
https://github.com/clipperhouse/displaywidth
Measure the display column width of strings in Go
go tui unicode
Last synced: 09 Oct 2026
https://github.com/micromatch/micromatch
Highly optimized wildcard and glob matching library. Faster, drop-in replacement to minimatch and multimatch. Used by square, webpack, babel core, yarn, jest, ract-native, taro, bulma, browser-sync, stylelint, nyc, ava, and many others! Follow micromatch's author: https://github.com/jonschlinkert
bash extended-glob extglob glob glob-matching glob-pattern globbing globby javascript matcher micromatch minimatch multimatch node node-glob regex regular-expression tidelift wildcard wildmat
Last synced: 09 Oct 2026
https://github.com/sindresorhus/is-retry-allowed
Check whether a request can be retried based on the `error.code`
Last synced: 09 Oct 2026
https://github.com/pimterry/loglevel
:ledger: Minimal lightweight logging for JavaScript, adding reliable log level methods to wrap any available console.log methods
javascript lightweight logging loglevel setlevel stack-traces
Last synced: 09 Oct 2026
https://github.com/darccio/mergo
Mergo: merging Go structs and maps since 2013
go golang hacktoberfest mapping merge structures
Last synced: 09 Oct 2026
https://github.com/C2FO/fast-csv
CSV parser and formatter for node
csv csv-format csv-parser csv-parsing nodejs stream typescript
Last synced: 09 Oct 2026
https://github.com/Azure/fetch-event-source
A better API for making Event Source requests, with all the features of fetch()
eventsource server-sent-events
Last synced: 09 Oct 2026
https://github.com/playwright-unofficial-community-archive/expect-playwright
Expect utility matcher functions to simplify expect statements for the usage with Playwright Test or Jest Playwright.
e2e-tests expect jest playwright playwright-test-runner testing testing-tools
Last synced: 09 Oct 2026
https://github.com/Microsoft/window-post-message-proxy
A generic messaging component for orchestrating promise based messages to/from a hosting application and an iframed component over the window.postMessage API.
Last synced: 09 Oct 2026